Paddy the 2013 Bitsaremissing Challenger

Anything specific to the Mitsubishi Challenger goes here!

Re: Paddy the 2013 Bitsaremissing Challenger

Postby coughy on Wed Mar 23, 2016 7:23 pm

each time was it on boost for more than 40ish seconds??? while going up hill???
if so it is boost over run from turbo not auto as these muppets say
i have found that in my limps (and i have had a few is to say the least) it is the poorly programmed ecu that controls the boost as it lets it runaway and cant catch it in time then it just drops out all of the boost and you are in a whole world of shit and arse kissing right there...

can u put camper on and go up a long incline and foot to the floor so lots of boost made and keeped there
so it is pulling all the way up the hill for more than 45sec it will do it again i debt if i was a debting man
then clear the code and lights by restarting the car about 10ish times and the lights will go off by them self as the ecu is happy that the car runs fine and no turbo boost run a way is happening and ecu is happy to start normally

when car is fine and running with no lights do the exact same thing but this time about the 30 to 35 sec mark lift the right foot momentarily and then mash it to the wall again it will not go in to the limp mode this time i debt im right ...

if this test is done and it works out like I say you have a temperamental map / turbo controller like i do and you will have to live with it or change them to see if it goes away

my m8 has a brand new pc chally and it does not do it at all gggrrr gives me the shits but mine does..

so next I'm thinking of getting a new map sensor and a turbo control solenoid to test and see if it fixes mine or if it is still a software issue

saying that there might be a newer software update that he has and mine don't...

let me know how you get on..
cheers coughy
Read this First ;) ;)Then still cant find what you are after
Use this Second ;) ;)Then still no Joy Go Here
Look in this thread 8-) 8-)
User avatar
coughy
Platinum Subscriber
 
Posts: 1551
Joined: Fri Jun 20, 2014 3:18 pm
Location: Bayside ,Brisbane ,QLD


 

Re: Paddy the 2013 Bitsaremissing Challenger

Postby Evil lurkes here on Wed Mar 23, 2016 8:22 pm

I'd be confident in saying it was boosting whilst going up the Maleny Road for way more than 40 seconds at a time. One thing I just remembered was that I saw the temp gauge move (just a lilttle bit) half way up the hill so I buttoned off. I still think my progress even at the slower pace would've required boost though. The temp reverted back to normal a short while after buttoning of.

But the limp mode thing didn't actually happen till about 10 minutes after the climb had finished and the temp gauge had normalised. It happened once I had actually been through Maleny. As I said before no lights came on the dash at all. It just stuck itself in 2nd gear. I had the shits with it by then so I drove the last 7 klms in 2nd gear at 45 kph.................traffic behind me didn't like it much but I have been stuck behind slower cars on that same piece of road.

Either way I will probably have a talk with the stealership tomorrow to try and sort this poop out.
Evil lurkes here
 
Posts: 121
Joined: Sat Aug 02, 2014 6:24 pm

Re: Paddy the 2013 Bitsaremissing Challenger

Postby Tony on Wed Mar 23, 2016 8:51 pm

The transmission goes into safe mode (stays in second gear) when heat duty exceeds its threshold.

Good luck with the dealer if you have any aftermarket bar work etc.
User avatar
Tony
Platinum Subscriber
 
Posts: 7020
Joined: Fri Dec 04, 2009 10:50 am
Location: Central NSW 100kms N/E of Mudgee

Re: Paddy the 2013 Bitsaremissing Challenger

Postby Challengerpb on Sun Oct 01, 2017 7:06 pm

Hi All,

Will fitting a Dawes valve to the PB Challenger sort out the over boosting issue going up long hills towing ?

The turbo seems to spin up quicker and over boost with a 3" ss exhaust before the controller can catch up and logs a fault throwing it into limp mode.

Thanks.
Challengerpb
 
Posts: 5
Joined: Sat Feb 15, 2014 5:02 pm

Re: Paddy the 2013 Bitsaremissing Challenger

Postby L200Shogun on Sun Oct 01, 2017 7:18 pm

Challengerpb wrote:Hi All,

Will fitting a Dawes valve to the PB Challenger sort out the over boosting issue going up long hills towing ?

The turbo seems to spin up quicker and over boost with a 3" ss exhaust before the controller can catch up and logs a fault throwing it into limp mode.

Thanks.

the answer is in here somewhere viewtopic.php?f=23&t=12233&hilit=overboost
User avatar
L200Shogun
 
Posts: 730
Joined: Tue Nov 04, 2014 8:48 am
Location: Perth WA

Re: Paddy the 2013 Bitsaremissing Challenger

Postby Challengerpb on Sun Oct 01, 2017 7:56 pm

Thanks L200,
Good read, I'll follow up getting the Dawes valve.
Challengerpb
 
Posts: 5
Joined: Sat Feb 15, 2014 5:02 pm

Re: Paddy the 2013 Bitsaremissing Challenger

Postby coughy on Tue Oct 03, 2017 1:53 pm

in my case no a dawes didnt fix it
only way to stop the overboost is a remap for me
never had a overboost issue since running 24psi up a long hill with 2t van on the back
Read this First ;) ;)Then still cant find what you are after
Use this Second ;) ;)Then still no Joy Go Here
Look in this thread 8-) 8-)
User avatar
coughy
Platinum Subscriber
 
Posts: 1551
Joined: Fri Jun 20, 2014 3:18 pm
Location: Bayside ,Brisbane ,QLD

Re: Paddy the 2013 Bitsaremissing Challenger

Postby Challengerpb on Fri Oct 20, 2017 9:59 pm

coughy wrote:in my case no a dawes didnt fix it
only way to stop the overboost is a remap for me
never had a overboost issue since running 24psi up a long hill with 2t van on the back





Thanks Coughy,

I was hoping for a simpler fix but I'm sure you are right with this.
Challengerpb
 
Posts: 5
Joined: Sat Feb 15, 2014 5:02 pm

Previous

Return to Challenger Club

Who is online

Users browsing this forum: No registered users and 1 guest